Archlinux Pacman Update Fix

Sun 25 August 2013

I'm writing this up as a quick solution to archlinux's dreaded pacman update problem.

If your run pacman -Syu and get:

:: package-query: requires pacman<4.1
error: failed to prepare transaction (could not satisfy dependencies)

If you have yaourt installed simply update package-query through it and update pacman normally.

yaourt -S package-query
pacman -Syu

Make sure also to delete the SyncFirst option from /etc/pacman.conf

Category: Devops Tagged: archlinux bug

comments

Page 1 of 1